Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BH3.02 - solo4k

Discussion in 'Vu+ Solo4K Immagini Black Hole' started by paperino61, Nov 25, 2016.

  1. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Ciao a tutti sto iniziando a sclerare con il mio nuovo solo 4k; non riesco assolutamente a far partire openvpn . Da interfaccia non da segni di vita, se lancio fa telnet ottengo questo:

    root@vusolo4k:/usr/bin# openvpn_script.sh start
    Starting virtual private network daemon: client(FAILED).
    root@vusolo4k:/usr/bin#
    root@vusolo4k:/usr/bin# root@vusolo4k:/usr/bin# openvpn_script.sh start
    -sh: root@vusolo4k:/usr/bin#: No such file or directory
    root@vusolo4k:/usr/bin# Starting virtual private network daemon: client(FAILED).
    -sh: syntax error near unexpected token `('

    sul mio DUO non avevo problemi quindi il file conf è corretto

    AIUTO !!!!!!!!!!!!!!!!!!
    ciao e grazie
    g.
     
  2. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Mi rispondo da solo: ora funziona, quindi avevo fatto io qualche casino
    ciao e grazie
     
  3. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Ciao a tutti,
    Mi ricollego a questo post perchè ho un problema simile sul mio solo 4K.
    Ho acquistato un VPN Cyberghost, fatto i file di configurazione con i seguente tutorial:

    https://support.cyberghostvpn.com/h...eceiver-How-to-configure-OpenVPN-for-VU-Solo2

    Successivamente ho abilitato il modulo del kernel e attivato open VPN con l'autostart.
    Sembra tutto ok ma se da SHH uso il comando "wget -qO- http://ipecho.net/plain;echo" mi risulta l'IP del mio provider ADSL.
    Che ne pensate?Qualche suggerimento?
    Più tardi provo a far ripartire open vpn tramite telnet, per vedere se mi da qualche errore strano.
    Allego inoltre il file di log.
    Grazie
    Ciao
    Roberto
     

    Attached Files:

    • Log.txt
      File size:
      15.5 KB
      Views:
      4
  4. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Ciao, se vuoi postare qui i file di configurazione posso dargli un'occhiata.... magari riesco a darti una mano (mi RACCOMANDO: togli user e password)
    ciao
    p.s
    perchè dici sembra tutto ok? Quanod premi "verde" per avviare, funziona e nello "stato attuale" vedi "IN ESECUZIONE? Il tasto Blu ti mosta il log immediatamente ed eventuali errori
     
  5. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Ciao,
    In allegato trovi i files di configurazione.
    Il log che si vede premendo il tasto blu dalla gui di openvpn è già stato allegato nel precedente post 3.
    Dico che appunto è tutto ok perchè dalla gui openvpn risulta attivo e con avvio automatico ma, se guardo il mio IP esterno, vedo che è 86.6.10.165 (Telecom) mentre in realtà dovrei essere connesso al VPN.
    Allego, a titolo di esempio, due screenshot presi da IPLEAK quando il mio mac è connesso e non come client al VPN cyberghost.

    Che ne pensi?
    Quando puoi fammi sapere
    Grazie mille per la cortesia
    Roberto



    NO VPN:
    No_VPN.png


    VPN:
    VPN.png
     

    Attached Files:

  6. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Ciao, ti premetto che non son esperto ma ci provo:
    • secondo me nel path /etc/openvpn ci deve essere un solo file .conf oltre ai file .crt e .key (nel mio caso la parte dei certificati è inglobata nel file .conf, prova a togliere il file server.conf)
    • chiaramente ci deve essere il file a cui fai riferimento per le credenziali (nel tuo caso pas.key)
    • nel file cyberghost.conf, prova a mettere il riferimento al file pas.key in questo modo
      auth-user-pass pas.key
    • nel file cyberghost.conf credo che questa parte
      remote 1-it.cg-dialup.net 443
      dev tun
      proto udp​
      non sia corretta... se utilizzi UDP credo tu debba puntare alla porta 1194; la 443 funziona per TCP

    • per essere sicuro che sia corretta l'attivazione, la parte del log deve terminare così:

      Wed Dec 19 06:46:26 2018 /sbin/ip addr add dev tun0 10.8.8.187/24 broadcast 10.8.8.255
      Wed Dec 19 06:46:26 2018 /sbin/ip route add 82.102.21.230/32 via 192.168.168.1
      Wed Dec 19 06:46:26 2018 /sbin/ip route add 0.0.0.0/1 via 10.8.8.1
      Wed Dec 19 06:46:26 2018 /sbin/ip route add 128.0.0.0/1 via 10.8.8.1
      Wed Dec 19 06:46:26 2018 Initialization Sequence Completed​
    • usa il comando route per verificare la situazione...se hai attivato correttamente vpn deve risponderti una cosa simile:
      Kernel IP routing table
      Destination Gateway Genmask Flags Metric Ref Use Iface
      default 10.8.8.1 128.0.0.0 UG 0 0 0 tun0
      default myfastgate 0.0.0.0 UG 0 0 0 eth0
      10.8.8.0 * 255.255.255.0 U 0 0 0 tun0
      82.102.21.230 myfastgate 255.255.255.255 UGH 0 0 0 eth0
      128.0.0.0 10.8.8.1 128.0.0.0 UG 0 0 0 tun0
      192.168.168.0 * 255.255.255.0 U 0 0 0 eth0​


    • ti allego il mio file .conf per eventuali confronti (chiaramente funzione per me con nordvpn) ....ma magari è utile per qualche spunto
    Spero questo possa aiutarti.......
    ciao
     

    Attached Files:

  7. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Ciao,
    Grazie per dritte!
    Ci studio un po qualche giorno e poi ti farò sapere!
    Saluti
    Roberto
     
  8. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Ciao,
    Sono stato più veloce di quanto previsto: in allegato trovi il file di log con la conferma di connessione al NorthVPN.
    Detto in poche e semplici parole e come facevi notare tu, la procedura di Cyberghost genera dei files di configurazione errati.

    NordVPN è invece sempre stata disponibile nelle scorse settimane, nonostante mi sia abbonato solo ieri, a darmi un supporto tecnico.
    Cyberghost di contro dicono che "non supportano Enigma 2 " ma poi fanno un tutorial dove sembra tutto sembra perfetto e funzionare ma non è, a conti fatti, così.

    Ringrazio nuovamente per l'aiuto.
    A risentirci
    Roberto

    PS: ho installato pure il seguente plugin utile per fare lo switch tra diversi VPN:

    https://vuplus-images.co.uk/index.php?threads/openvpn-config-changer-plugin.31239/
     

    Attached Files:

  9. paperino61

    paperino61 Vu+ User

    Messages:
    450

    Ciao, lieto di aver contribuito...... ero letteralmente impazzito per riuscire ad utilizzare openvpn (colpa della mia ignoranza :) ) poi, grazie alle dritte di qualche utente del forum mi si era accesa la luce.
    Grazie per l'indicazione del plugin (mi ero costruito qualcosa di simile quando utilizzavo gestori di vpn free), ma temo attirerai l'ira di qualche admin del forum..... mi sembra infatti non sia consentito fare riferimento link esterni ..... ma magari ti perdonano :)
    ciao e a rileggerci presto
    g.
     
  10. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Ciao,
    Solo per tua info: sullo stesso sito esiste anche un plugin specifico per nordvpn ma io il precedente citato perché più flessibile.

    Buone feste a tutti!
    Roberto

    Inviato dal mio ONEPLUS A6003 utilizzando Tapatalk
     
  11. Delfino

    Delfino Vu+ Newbie

    Messages:
    49
     
  12. Delfino

    Delfino Vu+ Newbie

    Messages:
    49
    Ciao,
    ho appena fatto un abbonamento a Nortvpn e possiedo un Vusolo 4k come il tuo. Mi puoi aiutare per capire cosa devo fare per poterla utilizzare con il mio decoder?
    Immagino che sia necessario qualche plugin o magari una semplice connessione in telnet ma non so veramente come procedere..
    Esistono dei passi sufficientemente semplici da seguire?
    grazie
    Delfino
     
  13. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Ciao, provo a vedere se riesco a darti una mano:
    • non ti serve nessun plugin
    • nel percorso /etc/openvn cancella tutti i file che trovi ora
    • scarica un file di configurazione .conf dal sito di nordvpn (il certificato è già presente all'intreno del file)
    • se prendi esempio dal file che ho messo in attacch qualche post più in alto, vedrai che è esattamente simile a quello che hai scaricato con la differenza che ho aggiunto la riga del log (log /etc/openvpn/openvpn.log) ed ho modificato la riga auth in questo modo (auth-user-pass ident) per fare in modo che le credenziali vengano lette dal file ident (io ho rinominato il file in .txt per allegarlo ma deve essere .conf)
    • crea un file chiamandolo ident ; deve contenere due righe: la prima è lo USER e la seconda è la pWD (le tue credenzili NORDVPN)
      Deve essere così:
    user
    password
    • copia entrambi i file nella cartella /etc/openvpn
    • tasto BLU - configurazioni avanzate - Pannello openvpn
    • giallo per fare in modo di attivarlo all'avvio
    • verde per attivare openvpn
    • il tasto blu ti mostra il log
    • se tutto ok da ora in avanti tutto il traffico transiterà attraverso la VPN (ad ogni riavvio ripartirà in automatico)
    • vedi mie indicazioni sopra per verificare (comando route da telnet)
    Spero di esserti stato utile
    ciao
    g.

    p.s.
    il file ident l'ho chiamato così ma chiaramente puoi chiamrlo come credi: l'importante che il riferimento nel file .conf (cioè la riga auth-user-pass ident) sia uguale al nome del file
     
    Delfino likes this.
  14. Delfino

    Delfino Vu+ Newbie

    Messages:
    49
    grazie mille per l'aiuto e spero che stia funzionando ma vorrei se possibile una tua verifica:
    ti allego il risultato del programma route se per te è più chiaro
    upload_2019-5-1_11-44-9.png
    (192.168.1.1 è l'indirizzo del mio router)
     

    Attached Files:

  15. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    88
    Buongiorno a tutti.
    A me sembra connesso al vpn.
    Per una conferma suggerisco di scaricare da vu-plus images i plugin ipchecker e vpn config changer.
    Il primo controlla ip esterno e interno. Il secondo solo esterno ma ti permette di fare uno switch veloce tra i server vpn (nel sito trovi le istruzioni per fare lo switch).
    Altra alternativa per fare il controllo dell'IP: usa chomium e vai su ipleak.net.
    Un saluto
    Roberto


    Inviato dal mio ONEPLUS A6003 utilizzando Tapatalk
     
  16. paperino61

    paperino61 Vu+ User

    Messages:
    450
    Ciao... mi sembra ok .....
    non prendermi per un saputello :) , ma mi sembra corretto dirlo: route è un comando che serve per visualizzare la tabella di routing (non lo definirei proprio un programma)...
    ciao
    g-
     
    Delfino likes this.
  17. paperino61

    paperino61 Vu+ User

    Messages:
    450
    dimentiavo.... per vedere e capire la differenza, esegui "route" con VPN disabilitato: ti sarà molto più chiaro
    cioa
     
    Delfino likes this.
  18. costandrea

    costandrea Vu+ Newbie

    Messages:
    4
    ciao a tutti. rispolvero questo argomento perche anche io ho problemi con openvpn. ho scaricato il file di paperino61 e modificato messo in etc/openvpn. modificato il file ident con email e password di nordvpn ma niente. ho attivato il vpn sia nei moduli kernel e sia in openvpn (blu.blu)
    Allego il log
    grazie a tutti

    Sun Jan 24 17:10:25 2021 OpenVPN 2.3.6 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Dec 11 2018
    Sun Jan 24 17:10:25 2021 library versions: OpenSSL 1.0.2a 19 Mar 2015, LZO 2.09
    Sun Jan 24 17:10:25 2021 WARNING: file 'ident' is group or others accessible
    Sun Jan 24 17:10:25 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
    Sun Jan 24 17:10:25 2021 Control Channel Authentication: tls-auth using INLINE static key file
    Sun Jan 24 17:10:25 2021 Outgoing Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
    Sun Jan 24 17:10:25 2021 Incoming Control Channel Authentication: Using 512 bit message hash 'SHA512' for HMAC authentication
    Sun Jan 24 17:10:25 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
    Sun Jan 24 17:10:25 2021 UDPv4 link local: [undef]
    Sun Jan 24 17:10:25 2021 UDPv4 link remote: [AF_INET]213.232.87.137:443
    Sun Jan 24 17:11:25 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sun Jan 24 17:11:25 2021 TLS Error: TLS handshake failed
    Sun Jan 24 17:11:25 2021 SIGUSR1[soft,tls-error] received, process restarting
    Sun Jan 24 17:11:25 2021 Restart pause, 2 second(s)
    Sun Jan 24 17:11:27 2021 WARNING: --ping should normally be used with --ping-restart or --ping-exit
    Sun Jan 24 17:11:27 2021 Socket Buffers: R=[163840->131072] S=[163840->131072]
     
  19. angelofsky1980

    angelofsky1980 BlackHole Driver Specialist

    Messages:
    17,114
    Visto così sembra un errore legato alla componente TLS.
    Sei sicuro che stai usando la key giusta per la tua VPN?
     
  20. costandrea

    costandrea Vu+ Newbie

    Messages:
    4
    Grazie della risposta. io ho messo nella prima riga del file ident la mia mail con la quale accedo al sito nordvpn e nella seconda riga la password con lettera grande annessa. il file ident non ha estensione giusto?
    perche nelle impostazioni di nordvpn trovo anche una voce che dice "service credential (manual step)" con una user ed una password. ho provato a mettere anche quella nel file ident per fare una prova ma il problema è lo stesso.
     

Share This Page