Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Impossible to update OBH image (ver. 4.2) in solo 4K/duo4k

Discussion in 'OpenBH General Discussions' started by don_hidalgo26, Mar 19, 2019.

  1. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    72
    Dear all,
    I've just flashed the latest OBH and, when I try to update the image, I've this strange message (see attached image).

    Do you have any idea how to fix it?
    I don't find the path in the menu but, in the same time, I'm not very happy to enable experimental updates...

    Many thans in advance
    Bye
    Roberto
     

    Attached Files:

  2. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,255
    Please, don't use smartphones to produce this difficult to read pictures! Many of them are also rotated!
    There is a PERFECT function under our images to grab the screen: use whatever browser, enter the IP address of your box followed by
    /grab
    and then save the picture in order to attach it here.

    About your issue: is it still happening? Maybe you tried while they were uploading new updates.
    If it's still so, as I can assure you there are any issues of any kind, try and change your DNS primary and secondary under your network settings.
    You can set them to use the google ones
    8.8.8.8
    8.8.4.4
    or the OpenDNS ones
    208.67.222.222
    208.67.220.220
     
  3. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    72
    Hi Alex,
    Many thanks for your prompt reply.
    About your questions, here below you can find my replies:

    1)Yes: my issue on updates is still happening. The surprising fact is that I've never had problems in updating OBH images in the last 4 months (from when I use OBH) and my network configuration has never changed in these 4 months!

    2)I'm actually using, from about 4 months and without problems, the DNS from my VPN provider (nord vpn) as follows:

    nameserver 103.86.96.100
    nameserver 103.86.99.100


    Concluding, I'll try to update OBH tomorrow evening and if I'll have the same problems I'll try your DNS.

    Bye
    Roberto
     
  4. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,255
    If you use a VPN this is, at the 99%, the reason for your issue.
     
  5. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    72
    Dear all,
    I've tryed to change DNS using both Google DNS and OpenDNS and my ISP DNS (TIM): the error in the update remains.
    Remark: I've also tried to reboot STB network with DNS changed but I have still the same error.

    The images are clean: I've flashed it yesterday and immediately run the image update.

    Do you have any other suggestions?

    Bye
    Roberto
     
  6. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,255
    Be sure it's not an image's problem, not only because I've always updated the image hundreds of times (only the 4.2, started from 4.2.001, is now at the 4.2.033 plus some other updates without the change of version, about 40 updates) but, above all, because no other one has never reported this issue.
    So, you have to investigate your network, your router and so on.
    Why did you have a VPN set? Be sure there isn't the same VPN set in the router. You could also save your current router settings and then reset it, to be sure.
    But only after having checked everything about your image network settings.
    And, the main question is: apart from updates, are you able to connect to the addons server (plugins, skins and so on)?
     
  7. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    72
    I'm also not able to connect the addons server except the official OBH updates :now I'm not at home so I cannot give you the exact "description" but it is the one with very few addons. For the others addons I have always the same error.
    Regarding VPN, every device connected to the router uses VPN with as client (eg. OpenVPN for Vu+STB). Inside the router there is only the DNS forced to NordVPN DNS: the remaining settings are standard ones.

    I think later I'll try to bypass the router connecting directly to my modem and try to run image update another time.
    I'll let you know...
     
  8. Shiro

    Shiro BH-C

    Messages:
    1,702
    Please test this:

    1) unzip file
    2) backup your file /usr/lib/enigma2/python/Components/OnlineUpdateCheck.py
    3) upload and substitute it with this file
    4) restart enigma2
    5) try to update image

    Let me know.
     

    Attached Files:

  9. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,255
    Interesting, don_hidalgo: this script seems to be able to "avoid DNS resolution" (as its comments say) and other solutions ;)
     
  10. Shiro

    Shiro BH-C

    Messages:
    1,702
    This should'nt be a DNS issue but is related to a system of traffic lights to moniotrize feed status (stable unstable and so on)
     
  11. don_hidalgo26

    don_hidalgo26 Vu+ Newbie

    Messages:
    72
    Dear all,
    Just to let you know: yesterday evening I tried another time to update the image and the update was working without the need to test Shiro's script.

    Bye
    Roberto
     
  12. nunigaia

    nunigaia Moderator

    Messages:
    5,187
    After the steps mentioned by @Shiro, and after image update, dont´t forget to delete "only" at the same location:

    Code:
    
    /usr/lib/enigma2/python/Components/
    
    
    The file named "OnlineUpdateCheck.py" .

    The other file named " OnlineUpdateCheck.pyo " might be maintained there, because is the compiled version, otherwise, when you get updates of the image the file will remain allways @shro version as it will overwrite the updated " OnlineUpdateCheck.pyo "

    best regards
    nunigaia
     
    Shiro and don_hidalgo26 like this.
  13. Shiro

    Shiro BH-C

    Messages:
    1,702
    Yes i know because the state of the feeds is now switched to "stable" so you don't need the modification.
    We will test the code and will update.
     
    nunigaia likes this.

Share This Page