Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IPTV channel zap

Discussion in 'Black Hole General' started by isostar, Mar 25, 2020 at 12:37 PM.

  1. isostar

    isostar Vu+ Newbie

    Messages:
    4
    Hi everyone,

    I have a VU+ Ultimo 4K running Blackhole 3.0.9 .L I added IPTV Buquets with JediMaker all is working fine, however I cannot zap with channel up & down buttons, I always need to go to the main list and select channels from there, but I would like to be able to zap the channels like the Satelite ones.
    I would appreciate if somebody can help me out in this matter.

    Thanks and stay safe.
     
  2. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,665
    In BH, unless you use a modified keymap.xml file, is not UP-DOWN but RIGHT-LEFT.

    If what you'd like to have is P+/P- k_e_ys for zapping instead that for bouquets and channel lists, you need to use a different file keymap.xml.
    Use the one attached and zipped and put it in
    /usr/share/enigma2

    Before that, I suggest to keep a copy of the original as, for instance, keymap.xml.orig
    or something like that.
    Remember you have to put again your file in that folder after major updates, because it will be rewritten.
    After having transferred this modified keymap, remember to restart the GUI.
     

    Attached Files:

  3. isostar

    isostar Vu+ Newbie

    Messages:
    4
    Hi Alexwilmac,

    Thanks for the reply, im happy with switching channels with right and left but this only works with my satellite channels when im switching to IPTV bouquets the left & right option doesn't work, I need to go back to the list view and select the channel there, I would prefer to zap without bringing up the list.
    I saw the thread where they explained how to modify the keycap.xml but this is actually not what im looking for.
    I hope I explained it well.
     
    Alexwilmac likes this.
  4. isostar

    isostar Vu+ Newbie

    Messages:
    4
    sorry Alexwilmac,
    I just tried it and your right it solved my problem.
    Thank you very much. Have a nice day
     
    Alexwilmac likes this.
  5. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,665
    You can't believe it, but... I'm surprised, too! Because I had sent this alternative keymap file just as a try and only because you wrote UP/DOWN.
    But, as what this keymap does is just and only to use P+/P- to zap instead of RIGHT/LEFT, it shouldn't do any difference for your problem! So, I'm surprised.
    But that's the IT world! Illogical things may solve issues.
    Actually, this is interesting because it means there is a specific mapping for IPTV channels (something I almost don't use, and anyway, I'm under OBH at moment, not BH, where the zap is already by P+/P- by default: so I could not know about this issue).
     
    isostar likes this.
  6. ZeljkoZep

    ZeljkoZep Vu+ Newbie

    Messages:
    21
    It's about StreamType mode
    If you set to DVB (1) then it works remotely just like it does on satellite channels.
    If it's another, then the remote works as you described, and then the Pause-Play function works.
    I do not have JediMaker, but I use an external tool (E-chanaliser). Basically try to replace Stream Type, if enabled by your IPTV provider.
    I use an alternative keymap.xml from zap to P+/P- so my experience applies to those settings.

    upload_2020-3-25_20-13-54.png
     
    isostar likes this.
  7. isostar

    isostar Vu+ Newbie

    Messages:
    4
    Thats an interesting fact, where can I change the stream type?
     
  8. Thomas67

    Thomas67 Vip

    Messages:
    481
    With jedi when you create your bouquets you can change the streamtype for Live, Vod and Series

    Just go back into Jedi and create new bouquets and where you see "Streamtype 4097" just press right and choose DVB1
     
  9. ZeljkoZep

    ZeljkoZep Vu+ Newbie

    Messages:
    21

Share This Page