Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Picons on Solo2

Discussion in 'Hardware: All Vu+ models' started by zedster4, Jan 1, 2020.

  1. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Hi, guys, sorry but I need some help again.

    Im using BH 3.0.9.L with MX BlueSea skin and I cant get any picons to display. I've spent hours trying to sort this out and searching for an answer but in the end have to ask for help.

    If I go back to the original BH skin and use the download manager, Picons Packages, then I can get some picons to work but for only one Satellite. If I load say 19E thats fine but then if I load 13E only 19E still works. The download manager puts the picons in /media/usb/picon

    Anyway, I ideally want to use the MX BlueSea skin and if I follow the same procedure as above the picons wont show.

    I have a 1Tb hard drive fitted so I assume the files are being put in the right place by the download manager. I've downloaded some picons in a zip file and unpacked them and transferred them using Filezilla to the same directory /media/usb/picon but this still doesn't work, but I don't know if this method is a correct way to do it.
    I read that /media/usb/picon is the best place for the picons to go as this prevents the HD spinning up after each channel change.
    All this hassle is the result of a system crash and I had to re-flash the receiver. I had picons before that but cant remember what skin I was using.

    Any help would be appreciated. Maybe point me in the direction of a set of picons that are know to work with MX BlueSea and where they should go helpful.
     
  2. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,673
    Skin have no role in managing picons.
    And yes, the only effective way to load picons is to use FTP transfer.
    Don't use any "automatic" procedure. I suspect that the last you used set your image to read picons from the flash itself (that's highly unconvenient) or, maybe, from HDD.
    Check if you have any picons in the original dedicated folder, that is
    /usr/share/enigma2/picon
    or in /media/hdd/picon
    If they were there, delete them or transfer to /media/usb/picon

    If they are not there and you are not able to create a symlink to point at USB, use one of the picons' addons specifically created for USB. When you see that this works for the satellite it was intended for (and it populated the folder /media/usb/picon), put all the other picons there by Filezilla.

    If you also have LCD4Linux installed, remember to change its picons' location within it preferences.

    I'd also delete the /media/usb/picon folder before this process and before starting everything over (and, of course, I'd delete the eventual /usr/share/enigma2/picon folder, if it exists.
     
  3. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Thanks for the reply. I checked all the directories you mentioned and cleaned them. I even had to re-flash the receiver at one point as I lost coms with it :wallbash: I then checked the directory /media/usb and this was empty. I then downloaded an picon package add on using the download manager and the /media/usb/ directory had been populated with the picon directory and files for 13E were there BUT they still wont load when switching a channel. There isn't another switch in the menu for turning the picons on of off is there?
     
  4. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,673
    What do you mean "won't load"? Where do you want to see them? In the channel list? In the Infobar? In the LCD display?
    I haven't on BH at the moment, but if what you mean is to show picons in the channnel list, I remember there was an option and probably it was under the Customization Menu.
    In the infobar, as soon as you create a folder "picon" under /media/usb, you'll immediately see them, without any setting to do.
     
  5. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Hi, sorry for the confusion. I mean I don't see them in the Infobar or channel list even if I tick the option in the custom menu. I dont

    As mentioned before. The only way I can get picons to show is if I load the original BH skin. Using the MX bluesea skin I dont see any picons even though they are there in /media/usb/picon
     
  6. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,673
    Do you install the skin MXblusea from the addons skin section or by an ipk package downloaded somewhere?
    And what happens if you install other skins (always from addons, of course)?
     
  7. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    I always install the skin from the addons skin section. I've tried the Blackshadow skin as well, with the same outcome, no picons showing. I will try again later just to clarify the situation as I've been round the houses so many times I've lost the will to live :laugh:
     
  8. newgolfer

    newgolfer Vu+ User+++

    Messages:
    829
    The Solo 2 don't have the LCD screen but VFD and the picons must not be enabled by LCD4linux plugins but by some menu settings.
    There should be an item in the menu settings asking where the picons are located and enabling them.
     
  9. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,673
    But, if I understood well, he's not talking about the LCD/VFD but of the Infobar and the channel list.
     
  10. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Yes, that is correct. Just the info bar or channel list
     
  11. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    A quick question. Are all the skins in the download manger available? I've just tried to download MX Maestra Blue and Blue 1 and even though the download says complete the skin is not showing in setup/system/skin :wallbash:
     
  12. p.rodrigues

    p.rodrigues Vu+ User

    Messages:
    185
    Is the pen mounted?

    [​IMG]
     
  13. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Something really strange is going on now :wallbash: Every skin I try and download doesnt appear in setup/system/skin and the download and installed messages seam to appear to quick
     
  14. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Do I need pen drive? When I download a picon package it puts them in /media/usb/picon so their there. Im not sure where "there" is in terms for hardware but I can see them. As mentioned before if I use the original skin from BH 3.0.9L i can get the picons to show and thats without a pen drive.

    I will go back to the original skin now just to satisfy my own mind that I'm not going crazy LOL Then I will try and load a different skin, if I can, see post above. Watch this space!

    Ok, I reloaded the original skin from BH and get a green screen of death to say a software error occurred. I've had this happen quite a few times now.
     
    Last edited: Jan 2, 2020
  15. p.rodrigues

    p.rodrigues Vu+ User

    Messages:
    185
    What should exist there are duplicate picons and possibly bad configuration. Put the picons all in one folder on your PC and save them.
    Save your settings all (channel list among others)
    On the disc erases everything related to picons. Formats the pen in FAT32 and creates a folder named "picon" without quotation marks.
    Put a new image, clean. Use only the image skin while setting it up. Do not forget the mount of the pen and then send by winSCP the picons to the folder that is in the pen.
     
  16. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Ok I did what you said. I had to re-flash the receiver after the software error message. I re loaded BH 3.0.9L and kept the original skin, formatted a USB drive to FAT32 and mounted it. ! can see the pen drive using filezila and I know its my pen drive as it has another directory on there called "system volume information"
    I copied over the picon files to the directory called "Picon" (without the " ")and this didn't work. I then deleted all the files in the picon directory and downloaded a picon package using the addon manger. This repopulated the picon directory with files but still they wont display in the info bar. Im not sure what else we an do apart from live without picons which isn't the end of the world but Im annoyed its beaten me.
     
  17. p.rodrigues

    p.rodrigues Vu+ User

    Messages:
    185
    Something's wrong ... how big the picons are. I use 220x132. Download these I send from Hotbird 13th (either delete what you have in the box or let it erase when you put these) and ask for a channel from that satellite.
    picon and not picons .....

    Code:
    https://www.sendspace.com/file/n4fi7j
    [​IMG]

    [​IMG]
     
  18. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,673
    FAT32??? I'm not sure this is the problem, but why on earth one should use such a limited file system like FAT32 when you can format it as extfs4? Use the image itself to do that.
     
  19. zedster4

    zedster4 Vu+ Newbie

    Messages:
    41
    Tried the file you sent, thanks.
    I changed permissions to 777 but wasn't sure what you meant by "and ask for a channel from that satellite"
    Anyway, that didn't work either.
    Something strange is going on.
    1. when I originally used the skin from BH 3.0.9L after a reflash I could get picons from a addon download but now I cant.
    2. I cant see any new skins I download even though it tells me its installed.
    3. I keep getting green screens of death with a software error message and the receiver re-boots or I have to re-flash.

    Do you think a factory default might help?
     
  20. p.rodrigues

    p.rodrigues Vu+ User

    Messages:
    185

    It's like I have ... if it's limited, maybe according to what you use. I don't know how many picons I have, surely over 3000 and I don't have any problem. The pen still supports IPTV cache if there is no hard disk, as is the case with my two Zero 4K. I already had a Solo2 and there was never any problem with the picons.
     

Share This Page