Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with Morpheus screensaver plugin from feeds

Discussion in 'OpenBH General Discussions' started by jrbmw, Oct 9, 2019.

  1. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    Running latest obh on vusolo 4k in flash and screensaver runs as it should ie I can choose the skin ...fish, tux etc.
    When I load latest obh image install in omb restore the settings and plugins I cant choose skin.
    The background and screensaver folders are in media/usb and the symlink in the extensions plugin morpheus points to there in the flash image but in the omb image it points to medi/autofs where there are no files.
    How can I correct this without not restoring the plugins and down loading it again ....which it then works

    Regards
     
  2. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,085
    I don't use your plugin and then I don't know it but... have you checked the file
    settings
    located in etc/enigma2
    ?
    It has got almost all the configurations of your system and your plugins. Maybe you can edit the paths you need so that you can use the /omb root for the symlinks you need without having to reinstall everything.
     
  3. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    One problem is the download disappears from the feeds once you install it, and I cant find the latest version anywhere to reinstall it.
    Ive tried editing and changing the symlinks with dcc but it doesent work.I cant understand why the link changes when the screensaver and background files are in media usb
    Also whe I try to put the two files in autofs it says unable to .
     
    Last edited: Oct 10, 2019
  4. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,085
    Probably because you installed the omb in usb and the images in omb have many links remapped. Did you try what I suggested to point at /omb instead of /mrdia/usb ?
    Otherwise we are going on in vaine.
     
  5. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    No the symlink stays pointing to autofs.Even tried loading the image to omb upload instead of usb.....same result
     
  6. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,085
    Of course the symlink are pointing to AutoFs: I'm trying to suggest you to edit the file "settings" and manually edit the path according to your wishes.
     
  7. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    The settings in etc enigma 2 are just a mirror of the plugin

    config.plugins.Morpheus.media=1
    config.plugins.Morpheus.nokeyaction=Movie
    config.plugins.Morpheus.radio=1
    config.plugins.Morpheus.stopped=1
    config.plugins.Morpheus.theme=fish
     
  8. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,085
    So, unfortunately, there is no path specified in settings. This means your plugins need to be be reconfigured in the omb's image from scratch in order to point at the right paths (hopefully).
     
  9. Thomas67

    Thomas67 Vip

    Messages:
    444
    If possible just add 1 more usb memorystick mount as media/usb
    /omb is the same as flashmemory and for your protection this plugin and many more have been blocked from using flash memory for obvius reasons ;)

    Allways keep omb in its own dedicated usb memorystick or at least if you have a large stick
    use the Usb Format wizard and create 2 partitions then you allways have the option to mount the partition without omb as what ever you want.

    When a plugin search for autofs its because unmounted devices can be found there and not the flashmemory :)
     
  10. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    The usb stick is 32gb with one partition and only has omb and epg on it
    The plugin works ok in flash or omb image when installed from feeds.The symlink only points to autofs when the plugins are restored .
    Unfortunately you cant check the usb is mounted before the plugins are restored
     
  11. Thomas67

    Thomas67 Vip

    Messages:
    444
    Well you dont have any mountpoint so of cause the restore cant find media/usb
    With 32gb i recommend partition the the stick and give omb maybe 5-6 gigabite and mount as media/personal or something else
    then install omb on that partion. The other mount as media/usb in the flash for epg and other stuff like picons

    When booting in to omb image you have the option now to mount this second partition as media/usb and then restore your plugin
    now it should work just fine.

    Your current setup will give you only 1 mount as /omb and when restoring there is nothing to restore to
    even if your /omb is 32gb. /omb will be identified as flashmemory by the Personal Restore plugin.
     
  12. jrbmw

    jrbmw Vu+ User

    Messages:
    237
    Thanks Thomas67
    created the partions and now restores the pluigin ok

    Regards
     
  13. Thomas67

    Thomas67 Vip

    Messages:
    444
    Allways nice when things works out :)
     

Share This Page