Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No up and down possible in Rec,Play& Timeshift submenus

Discussion in 'OpenBh General Discussions' started by Alexwilmac, Mar 20, 2021.

  1. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    I already posted about this issue also in ViX forum because the it affects also ViX 5.4.008.

    I found out that only in the two submenus Setup/Recording, Playback & Timeshift, is not possible to go down in the options list.

    It happens only in these two submenus, as far as I know and, obviously, it does not depend on the RCU because
    1) it does it with every RCU units I've got;
    2) It does it also by OWIF.
    3) It does the same also in OBH 4.4.008.

    So, remembering the other issue discussed some days ago in the Tuner terrestrial scan, I tried replacing Recordings.pyo and Timeshift.pyo from older images.
    Replacing the two files above mentioned taken from 4.3.039 in /usr/lib/enigma2/python/Screens at least Timeshift submenu works, whilst Rec&Play crashes.
    I then tried Recording.pyo from 4.4.001 but it's the same.

    But the issue it's almost surely due to some change in these two files or also some other ones. Surely it is because of Timeshift.pyo.
     
    Last edited: Oct 13, 2021
  2. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    I did other tries to check if it was a image-related or a OMB-related issue.

    At the beginning I was able to try only with Solo4K (in OMB) and Zero4K in flash.

    In Zero4K there's OBH 4.4.008 and, surprise, there it works Recording & Playback submenu and not Timeshift menu.
    I repeat: works means you can move the cursor down.

    So I started Solo4K from flash with OBH 4.4.003, just to see if running from OMB might cause the strange behaviour and, actually, both some menu work!

    As a final try, I performed a full backup of this image working in flash and loaded it as a OMB image and there both submenus don't work.

    So, it seems a OMB-related issue.

    I also tried OATV 6.4 from OMB and there there was no issue.
    So, I decided to use its files (as they work also from OMB)
    Recordings.pyo
    Timeshift.pyo
    and they work also for OBH.
     
  3. Ev0

    Ev0 Administrator

    Messages:
    3,012
    You have corrupted something in your image.

    There is no issue in either sub menu with scrolling up or down, with the image in flash or in OMB.

    If you must insist on messing with your boxes / images, please install 1 image in OMB that you keep "clean" so you can boot to that and check if problems really exist before you report these "issues".
     
  4. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    It's exactly what I did, Ev0. As I reported I also started from clean images but you always doubt about my actions: why?
    I just try to report issues, not to criticize our beloved images and, this way, I try and give my little contribution.
    After 36 years of IT experience, I know how IT can be tricky and how to isolate the variables of a problem.
    I installed new instances of both OBH and ViX in OMB, totally clean, and the issue was there. But, OK, tonight I'll do it again, for the 2nd time. If you don't believe me, I can film the procedure.
    And, if exactly the same image, I mean exactly the same installed image, OBH 4.4, perfectly work in flash but, when moved by its full backup, doesn't in OMB, this should be interesting.
    And, if using just different pyo files, recordings.pyo and timeshift.pyo, taken from OATV, makes the issue to disappear, it should tell something.
    And, if in Zero 4K, a completely clean 4.4 installed in flash, has the same issue in one of the two submenus...
    I couldn't try also in Duo2 but this two ones don't behave completely well.
     
  5. Ev0

    Ev0 Administrator

    Messages:
    3,012
    It's not that I don't believe you, it's that I know you like to play with your images and this in itself can create issue's.

    Also I have tested myself with both Ultimo4K and Duo4KSE and can not replicate the issue.

    ViX team also reported to you that they can not replicate the issue.

    So now do you see why I suggested what I did ?
     
  6. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    I don't mess my images, Ev0.
    If you did not have the same issue with other boxes, you are quite experienced to know that some issues are box-related. For instance, the Big PiP issue affects only my Solo4K, not also Duo2.
    And I also mentioned the different behaviour in the Zero4K, where a clean image, too, have this bug from flash but only for one submenu.
    I'll also try the Duo2 when possible.
    I perfectly believe you when you say you did not experience the same issue but, as I say, this means nothing.
    What they said in the ViX forum is also not reliable, in case this issue is model-related and they tested just another box.
    Surely, I can't own all VU+ model: I have 3 of them. So, it's not me the right person who can test 100% of the models.
    Anyway, I did a little movie of the very first boot up of a clean 4.4 image from OMB (from Flash no problems by Solo4K; only, partial, by Zero4K).
    I also did another thing, before that because, believe it or not, I'm not so naive: I also reflashed my box by OBH 4.4 and updated it. Then I launched a clean 4.4 from OMB. I hope this is enough to state these instance are not messied up.

    In the movie I cut just some frames not to hide anything but only to accelerate it. The link is this:
    Code:
    https://www.mediafire.com/file/4b4ha2swhdny232/OMB-submenus-issues.mkv/file
    After the boot, it starts the wizard but I skip every wizard steps and I go directly to Recordings submenu: it does not allow me to go down. Same for Timeshift one. So, this affects already 4.4.001 for Solo4K.

    Now, coders can do whatever they like with this test: I start to be not interested any longer. As I said, I already solved by OpenATV pyo.
    But I want to say that this is not the way to treat a user who try to help and, despite a lot else to do, does not just do superficial tests but very deep and logical ones. And this is only not to accuse coders of their terrible mistakes: I used to be a programmer in the past, and I know how easy is to have a bug in a software and how long it takes to find out its origin! So, I'd never criticize for a bug.
    I do these tests only in the interest of everyone and, before posting, I always go deep into the issues. That's all.

    Regards
     
    Last edited by a moderator: Mar 26, 2021
  7. Ev0

    Ev0 Administrator

    Messages:
    3,012
    You reported an issue, I tried to replicate the issue, vix team also tried to replicate the issue and neither of us could, so what do you expect me to say ?

    You have previously reported issue's that nobody could replicate either.

    I simply asked that in future before you report any bugs that you find, that you use a clean image (with no backup files, no plugins, no replaced files) to confirm it really is a bug before you post to save me (and others) hours of messing about trying to replicate a bug that may not actually be there, and you took offence to it.

    You say you don't mess with your images, then you say you fixed the issue using pyo files from a different image, so what do you expect me to think ?
     
    Last edited by a moderator: Mar 26, 2021
  8. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    Oh my God!!!! I fixed the issue for another instance, not for the one I showed you or I talked about!!!
    I'm not so stupid: did you read what I wrote? BOTH FLASH AND OMB WERE CLEAN IMAGES in the tests: my one, the one I use everyday is a different one. And I was very clear in writing that. Please.
    Please, read carefully my VERY DETAILED report and I also attached a video! Where is my fix in a just born install in that video?

    Only part I can't show you is that, the image in flash, where OMB runs from, is clean too: no plugins, no settings, nothing. Just launched, and stop.

    The fact you and ViX were not able to replicate surely depends on a variable on the specific image for Solo4K. Have they tested on Solo4K?
    Have you tested Zero4K in flash (yes, this one in flash, and not in OMB!)? Test it and see what happens: only one of the two submenus allows you to move down (I don't remember which one, and I can't check it at the moment. I believe it was the Timeshift one).

    Why a clean image (and also a not clean one) works perfectly from flash in those submenus (the Solo4K one) and not from OMB?
    Why a clean image for Zero4K, partially works from flash? (I haven't tried to test also in OMB in Zero4K, too, but I'll do soon).
    Clean, clean, clean images. And clearly, clearly, clearly it's a model-dependent issue. Until someone won't try also the Solo4K, it's not serious to make statements; it's not what an IT technician would do.
    I've never claimed this is a all-models issue, as soon as someone told me it could not replicate it.
    And that's why I immediately tried on another box. I've seen other different behaviours between a box and another one although using the same image.
    And, please, before making pass for a person who reports false issues, list which ones are you talking about, otherwise it's not fair to accuse someone.
    I remember when I reported an issue with a PAT error in BH 2.1.7 when switching from a Tivusat encoded channel to DVB-T never happened in the previous versions which @angelofsky1980 could not replicate; until he published a confirm and wrote in big, bold and red letters that the bug really existed.

    Regards.
     
    Last edited: Oct 13, 2021
  9. Ev0

    Ev0 Administrator

    Messages:
    3,012
    I have more important things to do with my limited spare time, than to waste it arguing with you on a forum.

    I am not an IT technician, this is just a hobby for me (and the rest of the team, we do it for fun in our spare time, nothing more).

    I made a request, you took offence to it (no idea why and no longer interested to find out why) and now want to argue about it, I have no time for that.
     
  10. el bandido

    el bandido Vu+ User

    Messages:
    432
    The pyo files, recordings.pyo and timeshift.pyo are compiled versions. The uncompiled or readable versions of these files are available on the Internet at GitHub. These are .py files instead of .pyo.
    More than 90 percent of Open Black Hole images is OpenVix. Sources for Open Black Hole and OpenVix are also on the internet at GitHub.

    Looking at the uncompiled versions of timeshift and recordings files shows there is a difference in them between OpenVix and OpenATV. But nowhere in these files do I see a specific receiver or receiver brand being named or called. (Doing this is easy by using one of the programs that compares or shows file differences.)

    Since there is not anything I see in these two files that calls a specific receiver or specific make, I would suggest you look at multiboot to solve the problem. I see several images in your multiboot in the video you uploaded. Multiboot images have caused corruption before, and I am guessing that is where your real problem lies.

    If nothing else, you have it fixed by swapping two files, but then again, looking at the content of those two files or 4 files when you compare both sets, I do not see where or how installing those files fixes or fixed your problem.
     
  11. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    But:
    1) in Zero 4K it also happens in a clean image installed in flash, although only for the Timeshift submenu.
    2) It also happens in Duo2 (I didn't report that as well, as I'm no longer sure someone is interested and I'm not paid as well to do these tests ;)) in a situation where there is only one image installed in OMB.

    I know .py are not compiled and .pyo are, but I've just, in another instance, tried to check whether or not I could fix the issue and surely the OATV pyo did (in the "full" image I use in OMB.

    To sum up my tries, I tested all my 3 boxes, both from flash and from OMB. This is what happens (I repeat: clean images both in flash or in OMB):
    1) Duo2 and Solo4K both perfectly work from flash and not from OMB in both submenus.
    2) Zero4K behaves differently (and should tell something by itself): either from flash or from OMB, it works only the Recording submenu whilst the Timeshift one doesn't.

    So, it's strange and interesting your analysis about the lack of a call to specific boxes, because (at least me) I had this difference. I'm not a coder, but it must be related to something else.
    Thanks for your effort. I repeat: I did my test only with clean images and it was reproducible.
    I did not upload the same video about Duo2, but I can assure you that there was only one image installed in OMB.

    More, it does not happen to any boxes with OBH 4.3: might it be related to the new python used by ViX 5.4 and 4.4? I don't know: I quit programming many years ago, so I'm noone in the field of programming, nowadays. ;)
     
  12. Thomas67

    Thomas67 Vip

    Messages:
    727
    My suggestion si that you turn on debug logs from Menu >> System >> logs

    Then restart GUI and go through the steps where you have your issues when done restart GUI and check the log with the logmanager to see if you get som clue to what is going on
     
    Alexwilmac likes this.
  13. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    OK: I'll try as soon as I'll have the chance of restarting from OMB that occurrence of OBH. At the moment I had to give up and use OBH from flash...
    Thanks for your suggestion. I just hope a log will reveal something, as there is no crash: just a lack of action. :)
     
  14. Thomas67

    Thomas67 Vip

    Messages:
    727
    Just as info since it's not a real crash. When you open logmanager to check log files you must first press red button to be able and view the debug logs
     
  15. Ev0

    Ev0 Administrator

    Messages:
    3,012
    So to be clear.

    Which box do you have a problem with ?

    If Zero4K you are using usb stick correct ?

    If yes, what is the usb stick mounted as, /media/hdd, or /media/usb ?

    And does whichever mount it is using contain a movie and a timeshift folder ?
     
  16. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    It's detailed in post#11

    And yes, in Zero 4K, the USB stick is mounted as /media/hdd.
    Actually, though, I'd like to see thiss issue solved in Solo4K, the main box: the other ones are not so important and are mainly used by simple users.
     
  17. Ev0

    Ev0 Administrator

    Messages:
    3,012
    Please stop trying to confuse things.

    If you want me to look into fixing it, then we need to go 1 step at a time and 1 box at a time ok.

    So 1st issue is Zero4K.

    So you have usb stick, it is mounted as /media/hdd correct ?

    So do you have movie and timeshift folders on this usb stick ?
     
  18. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
  19. wawa16

    wawa16 Vu+ Newbie

    Messages:
    61
    what about me
    i have same problem to @Alexwilmac and I did not change anything to pic
    tried on omb and neooboot
    but in old version no problem ( 4.3)
     
  20. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,510
    Yes, 4.3 but also the first releases of 4.4. I also reported to ViX forum without success (their support is not very quick... ;) )
    Other images, don't have the same problem but it's not possible to use their .pyo files to fix the problem.
    Maybe I'll try again just to see what happens.
     
    wawa16 likes this.