Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange issue setting alias.conf in CrossEPG

Discussion in 'OpenBH Plugins' started by Alexwilmac, Oct 28, 2019.

  1. Alexwilmac

    Alexwilmac Vip

    Messages:
    5,193
    I've been using CrossEPG for many years and I've always been able to set alias.conf for the cases I need, specifically to copy EPG from SD to HD channels.
    The examples at the beginning of alias.conf are simple and easy to follow.
    But, lately, I can't get to my goal: copy the EPG from some channels, for instance some RAI channels (but only some, the ones I'll tell later) to the correspondent HD.
    This issue affects, among the others: Rai Movie, Rai Premium, Rai News 24 and other ones, but not RAI1, Rai2, Rai3 and others, for whom my alias.conf woks perfectly.
    Note that, I want to copy the EPG of the satellite version of the 3 channels above, which is the most complete one, usually about 5 days.
    It should be done very easily either by this line
    Rai Movie-RAI=Rai Movie HD
    or, to be even more sure, by this
    2136-3070-013e=Rai Movie HD
    or, also,
    2136-3070-013e=4536-30D4-013e

    just to talk about Rai Movie. Same issue for the others already mentioned.
    But there is nothing to do: it just does not work.
    Where do I fail? What puzzles me is that this scheme perfectly works for many other channels.
     
  2. Max

    Max BH Lover

    Messages:
    338
    I know it's an old post, but did you solved this problem?
    I'm facing to same trouble using alias.conf on CrossEPG with some RAI channels, Movie HD, Premium HD, 5 HD, 4 HD.
    EPG on the same SD channels is complete, but I'm not able to copy on the HD channels using alias.conf as usual.
    Thanks.
     
  3. Alexwilmac

    Alexwilmac Vip

    Messages:
    5,193
    It seems... (better be cautious with this sort of things...) I solved: use these two files:
    alias.conf in /usr/crossepg/scripts/alias
    rai.conf in /usr/crossepg/scripts/rai

    because this last one was very old and it's the one used by the RAI script.

    In alias conf there are also other useful settings for many other channels. Try and tell me.
     

    Attached Files:

  4. Max

    Max BH Lover

    Messages:
    338
    Thanks Alex, I replaed these scripts and applied 755 permissions, no go, Rai Movie HD and Rai 4 HD still empty, RAI Premium HD has just 2 events as before. The only one seems working fine is Rai 5 HD, as with my previous scripts. This thing is driven me crazy, there's not a logical reason, relative SD channels have the correct "many days" EPG, but alias seems not working.
     
  5. Alexwilmac

    Alexwilmac Vip

    Messages:
    5,193
    I understand you....
    Have you tried also the script RAI within the script section?
    The crazy thing is that the same files work in a mipsel Duo2...
     
  6. Alexwilmac

    Alexwilmac Vip

    Messages:
    5,193
    I spent some more time and found out some issues that made less effective the alias.conf I posted in post#3. I found out that some blank spaces I had left after commas had to be removed...
    So I corrected La77 issues (now it correctly copies from satellite its EPS) and other channels too.
    @Max
    Try this new conf file and report e se sei italiano, la prossima volta ci scriviamo direttamente nella nostra lingua ;)
    Non serve il riavvio dopo aver trasferito il file in
    /usr/crossepg/scripts/alias
     

    Attached Files:

  7. Max

    Max BH Lover

    Messages:
    338
    Grazie Alex, lo provo appena riesco a trovare un'oretta libera.
     
  8. Max

    Max BH Lover

    Messages:
    338
    Situazione migliorata qui, ma RAI Movie HD, Premium HD, 4HD, 5 HD e probabilmente anche altri, mi mostrano solo 2 eventi nell'EPG.
    Boh! Ricordo che ci ero già passato molto tempo fa, ma stupiademente non avevo salvato i 2 script alias e rai funzionanti.
     
  9. Alexwilmac

    Alexwilmac Vip

    Messages:
    5,193
    Sì, in effetti, speravo di aver risolto ma, evidentemente, non erano stati gli alias a darmi più eventi.
    E' incredibile: il canale SAT Rai Movie ha un'EPG completa ma non c'è verso di copiarla sugli altri. Idem, ovviamente, per altri tipo Rai Premium.
    Ci riproverò, appena ricarico la dose di pazienza... perché questa cosa mi fa arrabbiare. E voglio anche ricontrollare se, come ricordo, su un Duo2 (che è Mips) lo stesso problema non si verifica. Se confermato, vorrebbe dire che il bug è nel codice del plugin stesso e riguarda gli ARM (nel mio caso il Solo4K).
     

Share This Page