Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhanced Movie Center (EMC)

Discussion in 'Vu+ Plugins' started by sat gr, Oct 18, 2013.

  1. nunigaia

    nunigaia Moderator

    Messages:
    5,122
    Enhanced Movie Center Git 1583 until ( 31/12/2018 )

    What´s New:



    • fixed rec icon position
    • raised EMCVersion
    • fix MetaSupport
    • workaround DreamOS PiG bug on dm9x0
    • added arab language
    • cleanup keymap.xml

    Enjoy it!, and report please any issue.

    Please test it and let me know!

    best regards
    nunigaia
     
    lulo and josagi like this.
  2. mirkoslav

    mirkoslav Vu+ Newbie

    Messages:
    30
    Can somebody help me here, as I still didn't reach anyone who has any idea about it. Namely, at first I was looking if there is EMC version for Arm (I have Duo 4K) which would support SubsSupport as it did one of the special versions for previous Vu processors. I thinks (last) SubsSupport version was 1.54 and it included special version of EMC which correctly started subtitles if they were in same folder and with same name as a movie (was working with .srt and .sub files just fine). These EMC versions do not start subtitles automatically with the movie (regardless how I configure it) and when I start them manually they are in wrong encoding, again regardless the language and other options I set in EMC. Is there any way to do it? I don't care if it's through EMC alone, or the way it was before where special version of EMC was released.
    What does EMC uses to play movies? Own media player or the one from the system? If the one from the system is there a way for me to subst MP with MP2 from SubsSupport, which does everything correctly, starts subs automatically and in proper encoding. If it's not clear by now, it's only about running the movies from my HD and NAS where they all have subs files in same folder. Right now I'm using MP2 to play them, but MP2 is poor soft when it comes to other functionality related to movies.

    Thanks in advance!
     
  3. nunigaia

    nunigaia Moderator

    Messages:
    5,122
    Enhanced Movie Center Git 1585 until ( 03/02/2019 )

    What´s New:



    Please test it and let me know!

    best regards
    nunigaia
     
    insanity and Alexwilmac like this.
  4. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,177
    Hi, nunigaia,
    I installed this new release and I'll be using it, that's sure.
    Even if OBH has no problems at browsing folders, I always keep installed also EMC, for instance for its feature of allowing the selection of many media files you can then play as a sequence.
    But I forgot is there is a way to display folders at the top along with an alphabetical order.
    I was almost sure there was such an option but I wasn't able to find it among preferences. Is it possible to do that somewhat?
    Or is it possible to add some lines to a EMC config file?
     
  5. Nikei

    Nikei Vu+ Newbie

    Messages:
    12
    How to fix this file for the display VU + Uno 4K SE. Now the information is very small in the upper corner of the display.
     

    Attached Files:

  6. Nikei

    Nikei Vu+ Newbie

    Messages:
    12
    Already done, everything displays perfectly.
     
  7. isenguard

    isenguard Vu+ Newbie

    Messages:
    44
    @Nikei
    How did you do that?
     
  8. nunigaia

    nunigaia Moderator

    Messages:
    5,122
    Enhanced Movie Center Git 1598 until ( 17/09/2019 )

    What´s New:


    • What´s New:
      • Update Deutsch language translation
      • Update Italian language translation
      • fixed ActionMap priority (adapting latest DreamOS changes)
      • Create Uk.po ( Ukranian language translation ) initial commit
      • Update Makefile.am
      • Update Ukranian language translation
      • fixed exception when reading EIT file
      • Update Italian language translation


      I´ve tested on BlackHole 3.0.9.I and OpenBH 4.3.009 and it seems there´s no issues until now.

    Please test it and let me know!

    best regards
    nunigaia
     
    KFL, Alexwilmac and bodo1960 like this.
  9. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,177
    I'll immediately start testing it (although in OBH it's not so fundamental as in BH).
    And I think I recognise the Italian translation! :D
     
    Thomas67 and nunigaia like this.
  10. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,177
    I see there's still the issue already reported by someone in the past: if you enter the EMC setup, save and exit, if you try and enter again, the box does not respond to any command and you need at least to restart the GUI by telnet.
     
  11. nunigaia

    nunigaia Moderator

    Messages:
    5,122
    > Italian translation lastest is updated on this version. ( surelly first you got at OBH, and only now for BH ) :)

    Ok, i noticed that now, by trying to reproduce the issue. ( done )

    In any case, the issue succeeds, because you haven´t done any modifications at setup, otherwise, you will got a message to restart enigma2 to apply settings. ( CAN YOU CONFIRM THIS )?

    I will open an issue at git, to report it, in order to get it fixed :)

    thanks

    best regards
    nunigaia
     
    Thomas67 likes this.
  12. Alexwilmac

    Alexwilmac Vip

    Messages:
    4,177
    I remember what happened but I wanted to test again to be sure: I did a change in the setup; then I exited (and saved the change). At this point I expected to be prompted about the need to restart the GUI. Instead it didn't ask anything.
    So I left EMC, I recalled it and the change had been applied even without the GUI restart.
    Now, I pressed again Menu and EMC Setup... and issue the occurred, exactly as the other times.

    Then (after a forced GUI restart) I tried to change something in the Setup and, even without the message about the GUI restart, I did it the same and (obviously) this time everything went fine entering EMC Setup after that.

    I find a good thing that you don't need to restart the GUI after a change in the EMC options, because you might be recording something and you wouldn't ruin the recording. But, if the issue can't be solved, at least it should be prevented to enter again the EMC setup before a GUI restart (better advising the user about this need).
    This way the user will be able to keep using EMC (also with the Setup changes he made) but won't be able to change a second option before a restart.
     
  13. nunigaia

    nunigaia Moderator

    Messages:
    5,122
    I have reported the issue on git, let´s hope that the dev´s will find a solution!

    best regards
    nunigaia
     
    Alexwilmac likes this.

Share This Page